upgrading to php 7.2If you’ve been working in  your WordPress dashboard recently (and I know you all have been), you might have seen red alerts and notices about upgrading to PHP 7.2 by the end of 2018. Upgrade, schmupgrade, amiright? Nope, not this time. Upgrading to PHP 7.2 is a must-do. Read on for why.

What is PHP, anyway?

PHP is the code that WordPress websites are built on, and its acronym origin story is actually entertaining: In the beginning it meant Personal Home Page Tools, but now stands for PHP: Hypertext Preprocessor, according to WhatIs.com. Personally, I think the original name made more sense. If you have a WordPress home page, your site starts and ends with PHP code.

Why do I need to update it?

Because the PHP your site is running may be dying, quite literally. And dead, unsupported software is like Swiss cheese for malware, hacks, link hijacking and worse. WordPress sites on PHP 5.6 run about half as fast as sites running PHP 7.2. And come Dec. 31, 2018, PHP 5.6 will enter End of Support. This is a tech term that literally means, “we’re not going to support that code anymore.” It get slapped on code languages when updates are so substantial, and patch such significant holes that running (and supporting) the former version becomes counterintuitive.

A faster site? Sweet!

While upgrading may be a pain you didn’t plan for this month, the good news is that if you’re in the need-to-do-it boat (i.e. if your site is running PHP 5.6 still), your WordPress site will enjoy significant speed improvements. According to my preferred host, WPEngine, most sites in testing “experienced up to 40% faster page speed, as well as greater memory efficiency, upon upgrade.” WPEngine feels so strongly about it that they’ll force upgrade or boot sites off of their server who don’t comply by March 2019.

Get serious about upgrading to PHP 7.2 today

Not sure which version of PHP your site is running right now? Ask your developer, ask your hosting company, or look in your hosting control panel. If it’s PHP 5.6 – act now, do not delay. If your WordPress site is running PHP 7 but not yet PHP 7.2, you have some time, but you need a plan. Reach out if you need help, don’t wait until it’s too late.